Infortel Select Classic NCQ Dashboard

Incident Report for ISI Analytics

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 12:35 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2026 - 22:44 CDT

Investigating

ISI is investigating an issue with NCQ widgets in the Infortel Select Classic Contact Center Dashboard not populating with data.
Posted Jul 09, 2026 - 00:37 CDT
This incident affected: Web Interface (Infortel Select Classic).