Inbound Support Calls

Incident Report for ISI Analytics

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 12:41 CST

Update

We are continuing to investigate this issue.
Posted Feb 09, 2026 - 09:19 CST

Investigating

We are currently experiencing an issue receiving calls to our support line. Please use our web form at "https://isianalytics.com/support/", or email "support-select@isianalytics.com" if you need to reach the Support Team.
Posted Feb 09, 2026 - 09:18 CST